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COMPUTER PROGRAM MANUAL

Material Requirement Schedule (MRS), Production Schedule (PS) and
Production Monitoring and Control (PMC) programs are developed with macro on
Excel software. Macro algorithm is provided at the end of the program worksheets.
While, the template of network planning model is established on Microsoft Project

software.

Installation
All of these programs are compressed into .zip file to be stored in one

diskette. Hence, it is necessary to decompress them before their applications.

1) Insert a disk containing .zip file
2) Type in “pkunzip <file name> .zip ¢:” this command will explode the hidden
file within . zip file to drive C

3) Press Enter
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FACILITIES MANU_IN MRS AND_PMC PROGRAM

Protect worksheet ( for MRS and PMC program )
Press Ctrl + Z

Unprotect worksheet ( for MRS and PMC program )
Press Curl + X

Hide columns ( for MRS and PMC program )
1. Click at top of column and drag to select required columns
2. Select Columns from Facilities menu

3. Select Hide

Unhide_columns ( for MRS and PMC program )
1. Click at top of column and drag to select required columns
2. Select Columns from Facilities menu

3. Select UnHide

Hide rows ( for MRS and PMC program }
1. Click at head of row and drag to select required rows
2. Select Rows from Facilities menu

3. Select Hide

Unhide rows ( for MRS and PMC program )
1. Click at head of row and drag to select required rows

2. Select Rows from Facilities menu

3. Select UnHide




Build up ending_point (only for MRS program)

1. Click at the red cell in front of item list which is next to the last item

2. Select Ending Point from Facilities menu

3. Select Build Up, ending point will appear as black cell at selected cell

Cancel ending point (only for MRS program)
1. Click at ending point
2. Select Ending Point from Facilities menu

3. Select Destroy

Build up navigator (only for PMC program)
1. Click at required cell
2. Select Navigator from Facilities menu

3. Select Build Up, navigator will appear as red cell with text “Click Here to

Update”

Cancel navigator (only for PMC program)
1. Click at navigator
2. Select Navigator from Facilities menu

3. Select Destroy, navigator will disappear

Move navigator forward (only for PMC program)
1. Click at navigator
2. Select Navigator from Facilities Menu

3. Select Forward
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Move pavigator backward (only for PMC program)
1. Click at navigator
2. Select Navigator from Facilities Menu

3. Select Backward

Build running bar (only for PMC program)
1. Click at head of required row
2. Select Running Bar from Facilities menu

3. Select Build Up, running bar will appear as blue strip along selected row

Cancel running_bar (only for PMC program)
1. Click at head of row of running bar
2. Select Running Bar from Facilities menu

3. Select Destroy
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MRS PROGRAM

B ll l I L] ]l » I l I ] l I l .
1) Copy file from MRS master program with the normal procedure by changing file

name

2) Key information from Bill of Material (BOM) into database
2.1) Select BOM from Sheets menu, BOM worksheet will appear

2.2) Key project information and name of production centre of that database

into green area as follows:

CENTER [E4] JOB No. [J4]
REQUISITION No. [E6) PRODUCT [J6]
ORDER SIZE [E8] BATCH SIZE [J8]

2.3) Key BOM information in green until complete every item as follows;

ITEM [C] DESCRIPTION OF MATERIAL[D] CLASS [E]
CODE [F] COUNT [G] USAGE / UNIT [Ij
SCRAP RATE (%) [J] REMARK [K]

3) Key matefiéls status and required date into databése

3.1) Select MRS Database from Sheets menu, MRS Database worksheet will
appear

3.2) Key required date of each batch for that production centre into green
area in row of REQUIRED DATE[11] by using information from Project Master
Plan

3.3) Key the quantity of current stock into column of CURRENT STOCK
[K], of required safety stock of into column of SAFETY STOCK[M] and of
materials on delivery of each item batch by batch in the row of SCHEDULE
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RECEIPT in green area until complete every item, by using information from

purchasing division and warehouse.
4) Build up ending point with the procedure of Build up ending point

5) Update data of every item in database by selecting MRS Update from Facilities

menu

6) Select All Database (if this command is selected without building ending point,
program will up-date all database and consumes long time. However, it may be

interrupted by pressing Ctrl + Pause Break)
7) Select Save from File menu to save file
8) Select Close from File menu to close file

9) Repeat step 1-8 for other production centres until completed

Revise material requirement schedule database by item
1) Revise darﬁ -'
1.1) In case that data about required date, current stock, safety stock or
materials on delivery is required to be revised
1.1.1) Select MRS Database from Sheets menu, MRS Database
worksheet will appear |
1.1.2) Revise data of the required item in green area only one item at
a time
1.2) In case that other data are required to be revised

1.2.1) Select BOM from Sheets menu
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1.2.2) Revise data of the required item in green area only one item at

a time

2) Update data _

2.1) Select MRS Database from Sheets menu, MRS Database worksheet will
appear

2.2) Click at red cell [B] in front of revised item

2.3) Select MRS Update from Facilities menu

2.4) Select One Item

3) Repeat step 1 to 2 for other required items until complete

4) Select Save from File menu to save database

Remarks .
~ In case of updating data without clicking red cell in front of iterﬁ list at

worksheet MRS database, program will show error. However, it can be corrected as
follows:

1) Click End at warning dialogue box

2) In MRS Database worksheet, click at ‘red cell in front of item which is
required to update

3) Select MRS Update from Facilities menu

4) Select One Item
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PMC PROGRAM and PS PROGRAM

Build up daily production schedule
1) Copy file from PMC master program with the normal procedure by changing file

name

2) Key weight of each process
2.1) Select Produciion Target from Over Views menu
2.2) Select Input Table, Production Target(Table) worksheet will appear
2.3) Press Ctrl + X to cancel protection

2.4) Key weight of each process into green area of column Weight[D]

3) Set up working day of the company

3.1) Key working day of the company into green area of row Date[6]
beginning in the first left cell as a few days before starting project in.the project
master plan to spare for starting project ahead of plan. Dates in the following cells
will automatically change in sequence for instance project starting date on 12/3/97,
10/3/97 should be keyed in the first left cell. Date in following cells will be changed
to 10,11, 12, 13, 14, 15, 16, 17, 18, 19, 20/3/97, ... respectively.

In case where 14-17/3/97 are non-working days, key 18/3/97 into cell which
represents 14/3/97. The working day will change to 10, 11, 12, 13, 18,19, 20/3/97,...
respectively. Repeat this step until exceeding the project completion date for a while

in order to spare for project delay.

3.2) Click at navigator
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4) Schedule daily production target

4.1) Open PS master program with the normal procedure

4.2) Key information about order size and batch size into green cells of
ORDER SIZE [E7] and BATCH SIZE {E9] respectively.

4.3) Key production capacity per day of a production centre which is
required for scheduling, in green cells of PRODUCTION RATE [EJ]

4.4) Key number of beginning and finishing batch continuously into green
cells of START BATCH [G14}, and TO [G16] respectively

4.5) Click and drag to select range of daily production schedule which has
been computed automatically in row of DAILY TARGET [26] from the first date to
the last date.

4.6) Select Copy from Edit menu

4.7) Switch to Production Target(Table) worksheet in PMC program

4.8) According to Project Master Plan, place active cell at the intersection of
starting date of the computed batch(es) and its production centre.

4.9) Select Past Special from Edit menu, dialogue box Paste Special Will
appear

4.10) Select Value in section of Paste

4.11) Select None in section of Operation

4,12 ) Click OK., daily production targef of that production centre will be
set.

4.13) Switch to PS program

4.14) Repeat step 4.4 t0 4.13 until completing every batch of that production
centre

4.15) Repeat step 4.3 to 4.14 until completing every production centre

4,16) Click at navigator

4.17) Switch to Production Target(Table) worksheet in PMC program

4.18) Press Ctrl + Z to protect worksheet
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5) Key project information

5.1) Select Project Information from Over Views menu, Project Information
worksheet will appear

5.2) Key project information into green cells as follows:

JOB No. [G5] PRODUCTION NAME [G7]

ORDER SIZE [G9] UPPER CONTROL LIMIT [G11]

LOWER CONTROL LIMIT [G13]

6) Identify project duration

6.1) Click at green cell of BASEDLINE DURATION [G15]

6.2) Key in =" symbol

6.3) Select Production Target(Table) worksheet by clicking at its label

6.4) Click at cell”which represents the ending date of project in row of
DATE[6]

6.5) Key in “ . symbol

6.6) Select Production Target(Table) worksheet by clicking at its label

6.7) Click at cell which represents the starting date of project in row of
DATE [6]

6.7) Press Enter, project duration will be shown

7) Key delivery date
7.1) Select Delivery Contract from Over Views menu
7.2) According to delivery contract, key the cumulative number of

distribution transformers which must be delivered in green area of Delivery Contract

[13]

8) Key items of Insulation production centre

-8.1) Select Insulation By Items from Centres menu
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8.2) Select Daily Pieces, Insulation Daily (Pieces) worksheet will appear

8.3) Press Ctrl + X to cancel protection

8.4) Key description of insulation and quantity which is required for one unit
of distribution transformer in green area of column DESCRIPTION [B] and PIECES
/ UNIT [C] respectively until completiﬁg every item

8.5) Press Ctrl + Z to protection

8.6) Click at navigator

9) Key items of Core cutting production centre

9.1) Select Core Cutting By Items from Centres menu

9.2) Select Daily Pieces, Core Cutting Daily(Pieces) worksheet will appear

9.3) Key size of silicon steel slit and quantity which is required for one unit
61’ distribution transformer in green area of column WIDTH (m.m.) [A] and PIECES
/ UNITS [C] respectively until completing every item

0.4) Click at navigator
10) Select Save from File menu to save database

11) Select Daily Update from Facilities menu to start program before keying actual

production result

12) Select Save from File menu to save database

1) Open file, which is required to update, with normal procedure

2) Key daily actual production result of Insulation production centre

2.1) Select Insulation By Items from Centres menu




162

2.2) Select Daily Pieces, Insulation Daily(Pieces) worksheet will appear
2.3) Key daily actual production result of Insulation production centre item
by item in green area until every item is completed

2.4) Click at navigator

3) Key daily actual production result of Core cutting production centre
3.1) Select Core Cutting By Items from Centres menu
3.2) Select Daily Pieces, Core Cutting Daily(Pieces) worksheet will appear
3.3) Key daily actual production result of Core cutting production centre
item by item in green area until every item is completed

3.4) Click at navigator

4) Key daily actual production result of other production centres
4.1) Select Actual Production from Over Views menu ‘
4.2) Select Input Table, Actual Production(Table) worksheet will appear ‘
4.3) Key daily actual production result of each production centre into green

area except Insulation production and Core cuiting

4.4) Click at navigator
5) Select Save from File menu to save database ‘

6) Update database
6.1) Check every worksheet to ensure that navigator in each worksheet has
been clicked already

6.2) Select Daily Update from Facilities menu

7) Identify delay or progress plan

7.1) Select Completion Day Forecast from Over Views menu
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7.2) Select Table

7.3) Click at green cell in the row of Acc. Current Delay [9]

7.4) Key in “=” symbol

7.5) Click at the label of %Completion & Performance Ratio worksheet,
Percentage Completion Performance Ratio table will appear

7.6) At the row of ACC. ACTUAL % COMPLETION (7], verify that how
much percentage the project actually completes at current date

7.7) Focus at the row of ACC. TARGET % COMPLETION [8] to compare
that when actual percentage completion from 7.6 should be completed. Then click at
cell in the row of DATE [6] which represents that date

7.8) Key in - symbol

7.9) Click at the label of %Completion & Performance Ratio worksheet,
Percentage Completion Performance Ratio table will appear

7.9) Click at cell in the row of DATE [6] which represents the current date

7.10) Press Enter

8) Select Save from File menu to save database

Remarks .

In case where there is at least one worksheet in which its navigator is not
clicked, when using Daily Update command, program will show error and show
warning dialogue box. Worksheet which appears at that time is the worksheet that
causes error. Because its navigator is not clicked. Hence, click End at dialogue box

and correct the error by using these following procedures.
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Close File without keepi ! tal
1) Select Close from File menu, dialogue box Close wiil appear

2) Click No, because database which is not completely updated is not needed to be
kept

3) Open file with normal procedure again

4) Check every worksheet, there must be at least one worksheet which its navigator
is not clicked (worksheet which appears during error). Once found, correct it by
clicking at navigator.

5) Repeat step 6 to 8 of the procedure of Update daily production result

This method is quick and less complex. Thus, it should be adopted as the
first corrective action. But if file 1s saved while closing it in step 2, error can be
corrected by reopening file again and using the Move navigator backward procedure

as follows:

Move navigator backward
1) Check each worksheet to seek worksheets which have been updated already
2) When wdrksheets which have been updated already are found, follow the
procedure of Move navigator backward
3) For worksheets which have not been updated, click at navigator and pass through
other worksheets

4) Repeat step 6 to 8 of procedure of Update daily production result
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‘Iable_B.l Daily ‘production report for Insulation production
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Daily Production Report

Division 105 Product Distribution Transformer kVA kv Phase
Production Cenlre Insuiution TF, JOB NO, LOT NO.
Operator Date
| Part 1 I
Descripion of Ruw Muteriuly Amount Working Period
Normal 0T,
Description of Insulations Production Result Working Period
Good Defect Nermal O.T.
Production Result
L
Reporter Duie

PEM-PIR-00-02 REY, 0




Table B.2 Daily production report for Low voltage coil winding

167

' Daily Production Report

Division - 108 . Product Distribition Transforiner kVA kv Phuse
Production Cenire Low Voltage Winding TF JOB NO. LOT NO.
Operator Date
Part | | Description of Raw Materials / Intermediate  Products Aniount Warking Period
Normul QT

|. Paper Cover Round Copper Wire diu, mm. {Ky)

2, LY. Thermopox {rollx)

A LV, Channcl (picvex)

THIHWIY

Production Result

Good

Defect

Noymual

O.T,

Production Result

Reporier

Dute

PEM-AW-242 REV, 0
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Table B.3 Daily production report for High voltage coil winding

Daily Production Report

Division 105 . Product Distribution  Transformer kVA 134 Phase
Production Centre High Volrage Winding TF 1OB NO. LOT NOQ.
Operator ’ Date
| Pan | I Dexcription of Raw Materiais / Intermediste  Products Amount Working Period
: Normul Q.T,
1. Copper Conductor din. m.m. (Kg.}
2.Tap Tube
X HV. Thermopox,
4. HV. Chumel

5 NV, End Insulntion

LT

Produstion Resule

Good Defect

Nemal

OT.

Production Resul

Repaorter

DAte

PEM-FRAIZ0L REY. 0




Table B.4 Daily production report for Core cutting
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Daily Production Report

Division 105 Product Distribution Transformer kYA kV Phase
Production Centie Core Cutting TF JOB NO. LOT NO.
Operator Date
| Pant | l
Deseription of Silicon Steel Slit Amount . Working Period
Normal oT.
I, Silicon Sieel Plute Width m.am,
2. Silicon Sieel Plate Widih n.m,
. Silicon Steel Plute Widih m.n.
4. Silicon Stee| Plale Width m.m,
& Siticon Steel Plae Widih ..
. Silicon Steel Plute Wirh m.n.
Description of Silicon Steel Plutes Produerion Result Working Period
Good Defect Mol o.T.
1. Silicon Steel Plate Widih m.m.
2. Silicon Sieel Pluse Widih .,
3 Silicon Steel Plae Width m.m,
4, Silicon Sicel Plare Widih ..
5. Silicon Sieel Plute Width n.m.
6. Silicon Siect Plate Width m.m.
Production Result
Reporter Date

PEM-FRAr1402 REV. 1




Table B.6 Daily production report for Punching
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_ Daily Pepduction Report

ivision 108 Praduct Dixtribution  Tomsformer kvVa kV Phase
Production Centre  Punching TF JOB NO. LOT NO.
Operator Date
Description of Silicon Steal Pl Amount (pieves) Working Period
Goaod Defect Normal a.T.
1, Silivan Steel Plate Width m.m.
2, Silicon Sweel Plue Widih m.m,
2 Silicon Steel Pluee Width m.an,
4, Silicon Siect Plae Widil m.Hk,
5. Siliven Steel Plae Widih nv.nn
6 Silicon Seecl PMlwe Width m.m.
Production Resukt
Reporter Date

PEM-RR-02402 REY. O




Table B.6 baﬂy production report for Core stacking -

J
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Daily Production Report

1Yivision 108

" Product

Production Centre Core Stacking TF

JOB NO.

Qperator

Distribution  Trunsformer

kV Phuse

LOT NO.

Dute

[ Part 1 | Description of Raw Muterisls / Intermediste Product Amount * Working Period
Normal Q.T,
L. Silicon Swel Plate Widih e, b,
2, Sikivon Sicel Plate Widih I,
A, Sitwon Stweel Plaie Wichh It
4, Siliwon Steel Plate Wicih 1k nk.
5. Silwon Srecl Plsie Widih 18
6. Silivon Steel Plwe Width in.nt,
7. Polyesier Rod din. m.nt (rods)
N, Core Clump
Y, Yoke Boh dia. m.m.
10. Winding Bolt dis. ma.
Working Period Production Reauh
Good Defent
Normul
QT
(
Production Result
Reporter Date

© PEM-AG-022 REV, 0




Table B.7 Daily production report for Core and coil assembly
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Daily Production Report

Division

108 Product

Production Centre

Operator

Core and Coil Assembly JOB NO.

Distribwion  Transformer

kva 142 Phase

LOT NQ.

Date

Part 1 ] Description of Raw Materisls / Intermediutc  Producix Amount Working Period
Normal QT
1, Core
1, Coit
X Inautution 5irip, Big
4. losulntion Stp, Smali
S Yuhe Imulison
6 Wookn Rod  diu. mm,
T, Wil Spawer Winding 1hick n.m.
A, W/l Specer Clamping thick ny.m.
Y, Wood thik .
1), Polyesier Angle Spucer
14, Sieel Plaie wam,
12. Sieel Plae mm,
L, Sweel Pluc .,
14, Swel Plae mm.
Working Period Production Resuli
Ciool Delect
Normal
Q..
{
Produciion. Resalt
Reporter Dule

PEM-FAN-0202 REV, 0




Table B.8 Daily production report for Tanking and oil filling
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Daily Production Report:

Division 105 Product Disiribution Transformer kVA kv Phuse
Production Cenire Tanking and Oil Filling JOB NO, LOT NO.
Operator Date
| Part | l Description of Raw Muteriuls { Intermediste Products Amount Working Period
Normal QT

L. Heuled Iniermediste  Dintribution  Trusformer

2. Trmaformee Tunk

3LV, Bushing

4, L¥.connecting bolt

5. HY. Bushing

6. HY, connecting balt

7, Drain Vulve

H. LHl e

4, Qil Level Gauge

1), Accessory, Nul (sel}

Working Period

Production Resub

Good

Delewt

Nomal

or.

Production  Result

Reporter

Dute

PEM-FW-I202 REVY. 1




Table B.9 Daily production report for Final assembly
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Daily Produétion Report

Division 105 Product Distribution Transformer kVA k¥ Phase
Production Centre Final Assembly JOB NO. LOT NO.
Operator Date
Part | I Description of Ruw Materials { Intermediate Produgis Amount Working Period
Nornval oT.

1, Tented | dinte  Diswiboiion Tranai

1 LY. Terninsl Conneclor

1 H.Y. Terminn) Connector

H. Naine  Plote

8, Comyguny  Plae

G A Bealher

7. Silign Gel (kg.}

4, ind Guard Cup

W Arcing & Lower Hom

10, L.V. & Enrthing Tenninul

Workiry Period

Production Resull

Cood Delect

Nomal

0.7,

Production Resule

Reporter

Date

FEM.FIN-0242 REV. 0
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Table B10 Weekly production report

Weekly Production Report

| Yivision 105 Product Distribution Transformer kVA
JOB NO. Lot NO. Date
Operations
Core Cutting

. Core Production

Core Stacking
2. lnsulation  Production
Low Voluage
3. Coil Production
High Voltage

Core & Coil - Assembly

1. Assembly Tanking & Qil Filling

Final Assembly

Reporter Date
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