
CHAPTER IV

DEVELOPMENT OF THE SIMULATOR

4.1 Computer Program of Distillation Calculation

The program developed by using c  language could be run under 
Microsoft Windows version 3.1 or later. The personal computer which have at 
least 386DX microprocessor with 4 MB RAM and VGA monitor could be run this 
simulator. The 486 DX2 with 8MB RAM is recommended. This simulator is 
composed of four parts as follows,

4.1.1 Input Data

Base on chapter i n ,  the rigorous model that requires a lot of input 
data is chosen in this work. The input data required for solving distillation 
problems are difficult to enter them into computer program due to its complexity. 
Then, the input tools are developed to enter the data easily. The details of input 
dialogs are shown as follows:

1) Components selection
Users can select components in the list which is shown on this 

dialog. It allows the user to select the maximum number of components up to 10. 
The warning m essage is automatically shown when the list of selected  
components IS changed. The selection of components must be done otherwise



27

Other parts of program cannot be run before selecting components, (refer to figure
4.1)

'Select Components M

List ot Compounds Seleted Compounds
1-1-dichlorotetrafluoroethane ♦
1-1-difluoroethene
1-1-dimethyl cyclohexane
1-1-dimethylcyclopentane
1-2-butadiene ■
1 -2-d i ch 10 r otetraf IU 0 ro et h a n e
1-2-pentadiene
1-3-butadiene
1-butene
1-butyne
1-chlorobutane
1-decene
1-heptanol
1-heptene
1-hexanol
1-hexene
1-methyl-2-ethylbenzene
1 -m e th y l-3-eth y I b e n z e n e
1-methyl-4-ethylbenzene
1-nonene *

♦

♦ n ♦
Indices Box

♦——
+

13 : r  - _______________1
Get Compounds

Set Compounds

Close

D  Deselect Mode

Figure 4.1 The Dialog for selecting component.

2) Selection of thermodynamic property models
Thermodynamic properties of vapor and liquid are estimated 

from one of three model, namely Ideal gas, Soave Redlich Kwong and Peng- 
Robinson models. Users can select the appropriate model from menu item 
“Properties package” in the Select menu. The PR I S  a default of this program.
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3) Column configurations selection
Users have to specify the column configurations, including

•  the number of stages
•  the number of feeds
•  the number of side streams
•  the number of energy streams (Side exchanger)
•  reflux ratio

The maximum number of stages is up to 100. It is 
illustrated in figure 4.2.
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> Figure 4.2 The Column Configuration dialog

4) Feed dialog determination
The operating condition of feed must be specified in this 

dialog are the feed temperature, pressure, flowrate with the composition, and the 
location of feed stream. This dialog I S  shown in figure 4.3.
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Feed Condition
Feed No. 1

ฅ์ไแทน่งสายซอน : น๋ันท๋ั
ฮุณแภมิ ะ ทนวย ะ

K i
กอไนคัน ะ ทน่วย ะ

bar ±
อัครไกไรไทล ะ ทน่วย ะ

kgmole/hr ±

สัคส,วนโมล..

ยกเลิก

คกลง

Figure 4.3 The Feed Dialog

Users can call this didog from the command menu or the 
active area of Feed in schematic diagram shown in the main window Users can 
input feed composition of each component in the didog which is displayed when 
the "สัดส่วนโมล..." button is clicked. The didog is shown in figure 4.4

Users may input molar flowrate for each component. This 
program will normdize the molar composition after the "ตกลง" button is clicked.
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Input Mole Fractions

Selected components Mole fractions
ไ methane
2 n-butane
3 n-pentane

-

OK Cancel

Figure 4.4 The Didog for input feed composition.

5) Vapor/ Liquid top product determination
Users select this didog from the command menu or activate it 

by double choking on the top product stream in the schematic diagram of 
distillation column. The data entered into the program consist of temperature, 
pressure and flowrate. There are two kinds of probable product which IS liquid or 
vapor, depending on the condition of temperature and pressure. The didog IS 
shown in figure 4.5.
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ฒ สายทล๋ัน pa)
อุณหภูมิ ะ หน่วย ะ

[เ- 1K 3 ตกลง ]
ควานคัน ะ หน่วย ะ

bar ฐ ยกเลิก
อัตราการไหล ะ หน่วย ะ

kgmole/hr ร
Figure 4.5 The Top Product Dialog

6 ) Bottom product determination
This didog is similar to the top product as shown in figure 4.6. 

The bottom product (สายก้นหอ) is liquid side stream from reboiler with flowrate 
which can be determinated by this program.

Figure 4.6. The Bottom Product Dialog



32

7) Vapor/Liquid side stream determination
A dialog for determining the side stream data which 

consists of flowrate and location of each stream can be chosen from Edit menu. 
It is convenient to input data in the didog as illustrated in figure 4.7.

[ท JE] บองเฑลวฅงออกฅัไนบ้าง
Liquid Sidestream No. 1

ฅำแแน่งท๋ัคง : ซ๋ันท๋ั

อัทรากไรไกล : ฑน่วย

ฅทลง

kgmole/hr É

ยกเลิก

Figure 4.7 The Side Stream Didog

8 ) Determining of heat transfer to/from each stage
Data of the heat transfer to or from each stage consist of as 

heat transfer rate and it’s location User have to enter heat transfer rates to or 
from all individud stages except stage 1 (condenser) and stage N (reboiler).
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ij|E ] กรในรอนคงออกบิ!ง
Side exchanger No. ใ

Cooling ± คกลง 1
ทน่วย ะ

kJ/hr ± ยทเลิก

Figure 4.8 The Didog for Entering Heat Transfer Data

Before running this program, it is recommended to check the input 
data from menu item “Check Input" presented in Report menu. However, the 
data can be changed by selecting the input didog and entering new data in the 
didog of the data which users want to change.

Table 4.1 summarizes the input data that must be input into this
program.



34

Table 4.1 Summary of Input Data

Input Data Details of Input Data
Mixture Component
Column Configurations The number of stages 

The number of feeds 
The number of side streams 
The number of heat transfer rates 
Reflux ratio

Feed

Product

Feed location 
Flowrate 
Temperature 
Pressure

- Vapor top product Flowrate
- Liquid top product Temperature
- Bottom product 

Side streams
Pressure

- Vapor side streams Flowrate
- Liquid side streams 

Heat transfer rate to or
Stream location

from stage Heat transfer rates 
Stream locations
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4.ใ .2 Database
This program is linked to the database developed by using c  

language. Thermodynamic properties and vapor-liquid equilibrium shown in 
chapter III can be calculated using data from the database and are sent to the 
calculation module, for solving the distillation problem.

Users have to select the model for estimating the thermodynamic 
properties of all components. For a nonideal case, Soave Redlich Kwong or Peng- 
Robinson will be used for calculating the properties.

4.1.3 Computational Procedure
The computational procedure used in this program was modified 

from Boiling Point method. The details of development was discussed in 4.2.

4.1.4 Output
The results of calculation are presented in tabular form which is 

displayed on Windows. Two windows show the results of simulation. The first 
window exhibits temperature, pressure, flowrate with the composition of each  
component, and enthalpies of vapor-liquid sidestreams, vapor-liquid top products 
and bottom products, see figure 4.9. The other displays temperature, pressure, 
and composition distribution in the column, figure 4.12. In addition, figure 4.13 
presents the temperature distribution with respect to the equilibrium stages.
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F ig u r e  4 .9  T h e  ou tp ut, w in d o w



Vapor Composition Profile -

comp ไ n-butane
comp 2 n-pentane " ......  1comp 3 propane OK

Vapor Composition 
Stage
No. Compl Comp2 Comp3
1 0.1708 0.0283 0.8008
2 0.3306 0.1599 0.5095
3 0.3464 0.3407 0.3129

Figure 4.10 The vapor composition window.
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F S B iB I- Liquid Composition Profile

comp 1 n-butane
comp 2 n-pentane
comp 3 propane OK

Liquid Composition 
Stage
No. Compl Comp2 Comp3
1 0.3306 0.1599 0.5095
2 0.3551 0.4392 0.2058
3 0.2707 0.6298 0.0995

W T

Figure 4.11 The liquid composition window.
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F ig u r e  4 .1 2  T h e  s t a g e  v a r ia b le s  w in d o w
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Figure 4.13 The temperature profile plotted on the output window.
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Vapor Composition.Profile. '
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0.7  
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0.3  
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+ n-hutane
Tray No.
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OK

*1 TT"

F ig u r e  4 .1 4  T h e  v a p o r  c o m p o s it io n  p rofile  p lo tte d  o n  t h e  o u tp u t  w in d o w .
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Figure 4.15 The liquid composition profile plotted on the output window.



ตนฉบบ หนาขาดหาย



44

Table 4.2 Summary of the output

Output Details of Output
Check To check Input Data

Product Flowrate
- Top product Composition
- Bottom product Temperature
- Side stream Pressure

All stages Temperature distribution 
Composition distribution

4.2 The Details of Calculation Procedure

The data input window is used to declare variables for the 
calcฟating part. The calculation procedure is shown as follows:

1) All of variables have been defined as zero when the column 
configuration is specified by users. One of 2 dimensional array equalร to the 
number of components and the other IS the number of stages rs the second  
dimension.

2) The input data rs changed to the single or two dimensronal 
arrays before calculating.

The single dimensional arrays are temperature (T), pressure (P), 
feed temperatures (Tj) 1 feed pressures (Pf), feed flowrates (F), vapor (V) and liquid
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(L) flowrates, vapor (พ) and liquid (บ) sidestreams and heat duties (Q). The 
indexes of those arrays are represented by numbers of equilibrium stage.

The two dimensional arrays are the phase equilibrium constant (K) 
and compositions of liquid, vapor and feed. Both indexes of the arrays are 
represented by numbers of components and equilibrium stages, respectively.

3) Variable initialization
The liquid bottom product from reboiler (LN) is calcฟated from 

overall material balance that given in equation (3-6).
The pressure of each stage are defined by equation (4-1).

P j = P i - 1 + ( P n - P  i) 
พ - !

where
PN is pressure of reboiler (Bar).
Pj is pressure of condenser (Bar).

(4-1)

The initial temperature of each stage is assumed to be linear from 
condenser to reboiler as shown in equation (4-2).

T j = T j  - 1 + (7^ ~  ^  (4-2)

where
Tn is temperature of reboiler (K).
T1 is temperature of condenser (K).

The vapor interstage is defined from overall material balance of
condenser.
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i
Vapor top product (Vj)

เ

Condenser

1 Liquid top product (บ1)

v 2 Li

Figure 4.16 The model of the condenser (stage 1).

The model in figure 4.16 is assumed to be no vapor sidestream (พ 1) 
and feed (F1). Then the overall material balance is yielded as

V2 = VI + U1 + LI (4-3)

The equation (4-3) has two unknown, but w e can find L1 from 
reflux ratio. The reflux ratio is defined as the molar ratio of the liquid returning 
to stage 2 to the total flow of the liquid and vapor top product.

R = y  (บ 1+'V 1) (4-4)
or
Lj = R l t y v  1) (4-5)

Substitute Lj in equation (4-3) by (4-5) to find V2.

V2 = VI + U1 + R*(U1+V1) (4-6)
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This program initializes V3 to VN to be equal to V2.
4) The simulator firstly calculates from ideal condition to estimate 

the liquid composition in each stage as the initial guess.
5) Bubble temperature is calculated to find new T.
6) Temperature is rechecked by equation (3-30) and equation (3-

31). Program terminates when the condition is true.
New V is determined from the method discussed in chapter III. 

Heat duties are calculated from equation (3-5) for the condenser and from 
equation (3-22) for the reboiler.



Figure 4.17 Flowchart of this simulator
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The distillation simulator displayed in this work is a Windows 
application consisting of the following main components:

— The frame window with the menu system, minimize icon, and 
maximize icon. The window has a title as “Distillation Column”.

— The conventional distillation column shown on main window  
displays the input didog of feed, top product, or bottom product 
when the left button is clicked at the active areas.

4.3 An Overview of The Simulator

null) (File) เลือก (Select) แก้ไข (Edit)
Distillation Column

แสคงผล (Report) คำนวณ (Bun) Help

Figure 4.18 The main window of distillation simulator.

The Menu shown on the main window consrsts of many commands. The 
details for using each command is given as follows
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The File menu consists of commands to start and to exit the 
application. The details of each command are shown in Table 4.3.

4 .3 .1  T h e  F ile  M e n u

Table 4.3 Summary of the commands in the File menu.

Command Function
New To create a new the distillation case

- show the column configuration 
dialog for enter the data.

- show the window for select 
components.

Exit To exit from the application.

4.3.2 The Selecting Menu
T h e  S e le c t in g  m e n u  p r o v id e s  c o m m a n d s  for s e le c t io n  o f

c o m p o n e n t s  a n d  m e t h o d s  for e s t im a t in g  t h e  th e r m o d y n a m ic  p r o p e r t ie s . T h e

c o m m a n d s  a re  s h o w n  in  T a b le  4.4 .



51

Table 4.4 Summary of commands in the Selecting menu

Command Function
Property Package... To select a method to calculate the 

thermodynamic properties.
Ideal Case Ideal case
SRK Soave Redlich Kwong correlation
PR Peng Robinson correlation

Components Select components
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The Edit menu provides commands to edit input data 
Table 4.5 summarizes the commands in Edit menu.

Table 4.5 Summary of the commands in the Edit menu.

4 .3 .3  T h e  E d it  M e n u

Command Function
Feed To input flowrate, conditions and 

location of feed streams.
Product To input flowrate, temperature and 

pressure of product
Side stream To input flowrate ad location of side 

streams
Energy Stream To input heat transfer rate and location 

of streams (except the condenser and 
reboiler duty).

Column Configuration Input Column Configurations, including
•  number of stages
•  number of feeds
•  number of side streams
•  number of energy streams
•  reflux ratio

4.3.4 The Report Menu
There are several commands for showing the input data and 

the results of calculation. Table 4.6 summarizes the commands in the Report
menu.
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Table 4.6 Summary of the commands in the Report menu.

Command Function
Check To show data that are input by user.

Input Data - Column Configuration
- Initial guess of product
- Feed
- Sidestreams
- side exchanger

Result To show the result of calculation.
Table - Product

- Vapor and liquid composition
Stage variables To show temperature, pressure and flow 

in column
Graph Temperature profile

4.3.5 The Run Menu
The Run command is used to run the program for solving 

distillation problems after all of necessary input data are defined.

4.3.6 The Help Menu
The Help file is very useful for users to start the simulator. 

The detail of help is following.
- How to use the simulator.
- Suggestion for input data.
- The column convention.
- The list of m essage from simulator.
The Help file of Distillation simulator IS shown in figure 4.19.
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File Edit Bookmark Help 
๗*1 Search I jack I History

Help for Distillation .Column

ส า ร ย ัญ  

• ข ั้น ต อ น ก า ร ใ ช !ป ร แ ก ร ม ส ำ ห ร ับ ผ ู้เร ิ่ม ต ้น

• ข ้อ แ น ะ น ่า ใ น ก า ร ป ้อ น ข ้อ ม ูล

• ร า ย ล ะ เอ ีย ด ข อ ง โ ป ร แ ก ร ม

• ร า ย ล ะ เอ ีย ด ข อ ง ค ำ เต ือ น ใ น ข ณ ะ ใ ซ โ ป ร แ ก ร ม

Figure 4.19 The Help file for distillation simulator.
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